Streamline 7.1 (English, SD701) - Released Now

A section for all development and testing programmes and customised browsers written by SillyDog701 community. Featured products including Donzilla, Firescape, DJGM Distro, and Netscape Streamline.

Streamline 7.1 (English, SD701) - Released Now

Postby Antony » Sun 20 Jul, 2003 6:09 am

EDIT:
Realeased now, 5th August 2003
The documention page is available at Netscape 7.1 Streamline information page.

The file is identical to Test Build 3.

Original message:
Yes, I created Netscape 7.1 Streamline.

This Streamline 7.1 is similar to previous builds, with ChatZilla included (optional).

Sorry, no detailed documentation is available yet. I will put the documentation about this build soon.

And it is customised with CCK 7.0 with a number of advanced customising involved. (a.k.a "fixing")

Build 1 has installation glitch.

Posting from Netscape 7.1 Streamline - build 2. Current size: 14.5MB.
I will upload it tomorrow. (Not yet uploaded, currently in dial up)

Beta testers wanted... particularly Windows 98 users.

A detailed documentation page will be available once it is official.

A detailed how-to guide on how to use CCK 7.0 + fixing tasks will be available after official release.
UserAgent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624 Netscape/7.1 (ax) (CK-SillyDog)
Last edited by Antony on Tue 05 Aug, 2003 2:34 am, edited 2 times in total.
User avatar
Antony
diamond member
diamond member
 
Posts: 15260
Joined: Tue 18 Jun, 2002 11:36 pm
Location: Sydney, Australia

Postby Antony » Sun 20 Jul, 2003 8:15 pm

Netscape 7.1 Streamline build 3 - 14.5MB Available for beta testing.

Build 3 fixed one installation glitch.

Feedbacks welcome.
UserAgent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624 Netscape/7.1 (ax) (CK-SillyDog)
User avatar
Antony
diamond member
diamond member
 
Posts: 15260
Joined: Tue 18 Jun, 2002 11:36 pm
Location: Sydney, Australia

Postby DJGM » Sun 20 Jul, 2003 10:10 pm

I've just downloaded Build 3, and installed it into a seperate HDD folder from the official version.

So far so good, but for some reason, having looked at the about: page, the UA string doesn't
display the (CK-SillyDog) tag. It just displays the standard default UA, with just the (ax) tag.
UserAgent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.4) Gecko/20030624 Netscape/7.1 (ax)
SeaMonkey = Swiss Army Knife: It's versatile, reliable, and contains useful tools.
Windows Internet Explorer = Old Swiss Cheese: Full of holes, and it stinks!
User avatar
DJGM
diamond member
diamond member
 
Posts: 4655
Joined: Wed 19 Jun, 2002 1:03 pm
Location: Manchester, England, UK

Postby Antony » Sun 20 Jul, 2003 10:52 pm

DJGM, did you suppress UA string? or using an old profile?

Tested in another machine, and shown correctly in both my main NS profile and a new profile.
UserAgent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624 Netscape/7.1 (ax) (CK-SillyDog)
Last edited by Antony on Sun 20 Jul, 2003 11:07 pm, edited 1 time in total.
User avatar
Antony
diamond member
diamond member
 
Posts: 15260
Joined: Tue 18 Jun, 2002 11:36 pm
Location: Sydney, Australia

Postby DJGM » Sun 20 Jul, 2003 11:05 pm

Since Netscape 7.1 was released, I created a fresh new profile. I've always
had seperate (but nearly identical) profiles for both Netscape 7 and Mozilla.
I'm using the same profile for this test build, as for the official version.
In which case, I'll temporarily create a new profile for testing.

BTW . . . What do you mean by "suppressing" the user agent string?
If that's the same as or similar to user agent string spoofing, then no.
UserAgent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.4) Gecko/20030624 Netscape/7.1 (ax)
SeaMonkey = Swiss Army Knife: It's versatile, reliable, and contains useful tools.
Windows Internet Explorer = Old Swiss Cheese: Full of holes, and it stinks!
User avatar
DJGM
diamond member
diamond member
 
Posts: 4655
Joined: Wed 19 Jun, 2002 1:03 pm
Location: Manchester, England, UK

Postby Antony » Sun 20 Jul, 2003 11:07 pm

No idea, DJGM, sorry.

Documentation page is up, not yet completed, but has addressed the difference between Netscape 7.0x and 7.1.

Components are different between NS 7.02 and NS 7.1.
Also, I renamed Netscape 7.1 Base to Navigator 7.1 Stand-alone. (Although the file is called base, the webpage in Netscape.com call it stand-alone.)

Since this Netscape 7.1 Streamline would probably be the last Netscape 7.1 Streamline (*), I would like to make it as good as possible.
If there's anything I can improve, please let me know.

Netscape has added a new Help files for NS 7.1

(*) It does not say that I won't release further Streamline series based on Mozilla.
UserAgent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624 Netscape/7.1 (ax) (CK-SillyDog)
User avatar
Antony
diamond member
diamond member
 
Posts: 15260
Joined: Tue 18 Jun, 2002 11:36 pm
Location: Sydney, Australia

Postby Antony » Sun 20 Jul, 2003 11:09 pm

Okay, I found mistakes in Documentation page, will fix it later.
UserAgent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624 Netscape/7.1 (ax) (CK-SillyDog)
User avatar
Antony
diamond member
diamond member
 
Posts: 15260
Joined: Tue 18 Jun, 2002 11:36 pm
Location: Sydney, Australia

Postby DJGM » Sun 20 Jul, 2003 11:09 pm

Now testing with a new profile . . . hmm, the (CK-SillyDog) tag is there . . . !
UserAgent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624 Netscape/7.1 (ax) (CK-SillyDog)
SeaMonkey = Swiss Army Knife: It's versatile, reliable, and contains useful tools.
Windows Internet Explorer = Old Swiss Cheese: Full of holes, and it stinks!
User avatar
DJGM
diamond member
diamond member
 
Posts: 4655
Joined: Wed 19 Jun, 2002 1:03 pm
Location: Manchester, England, UK

Postby Wellander » Sun 20 Jul, 2003 11:22 pm

Hi,
I downloaded it and I found it to work well except for tow problems that I found so far.

I can not use the radio@netscape web borwser based player.
(probably not a problem because I can not get it to work with any browser except Inetnet explorer)

The serious issue that I am expercing it the the mouse becomes disabled only with this build is open I will check out the mouse driver in windows 2000 to verify what is going on and check my event viewer too.

I will have more later when I find out more info.
UserAgent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624 Netscape/7.1 (ax) (CK-SillyDog)
Wellander
diamond member
diamond member
 
Posts: 2603
Joined: Mon 21 Oct, 2002 6:37 pm

Postby DJGM » Sun 20 Jul, 2003 11:27 pm

One thing worth asking . . .

Is there much point (if any) in including the Netscape Network activation/registration component
in CCK'd Netscape builds anymore? Going back in time to when Netscape released version 7.01,
it was pointed out by "Netscape Champion" Jay Garcia, that the activation/registration dialogs
should not by bypassed, as all registrations were audited by AOL. In Jay's own words . . .

Jay Garcia wrote:Netscape NEEDS your help!!

In order for Netscape to survive, it needs "numbers". Those "numbers" are
counted by the number of "registrations" entered when first installing the
application. In other words, how many users download and register the
product is the determining factor when AOL management audits usage.

Many users are "put off" by this registration process and look for ways
to circumvent this function which is understandable to a degree.
Please do NOT get around it, REGISTER. "Bite The Bullet" !!


Now that Netscape is all but gone, is the activation/registration component needed any longer?
UserAgent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624 Netscape/7.1 (ax) (CK-SillyDog)
SeaMonkey = Swiss Army Knife: It's versatile, reliable, and contains useful tools.
Windows Internet Explorer = Old Swiss Cheese: Full of holes, and it stinks!
User avatar
DJGM
diamond member
diamond member
 
Posts: 4655
Joined: Wed 19 Jun, 2002 1:03 pm
Location: Manchester, England, UK

Postby Antony » Sun 20 Jul, 2003 11:51 pm

DJGM wrote:One thing worth asking . . .

Is there much point (if any) in including the Netscape Network activation/registration component
in CCK'd Netscape builds anymore? ...
I did not disable it, but since Netscape disabled it themselves somewhere.
Now that Netscape is all but gone, is the activation/registration component needed any longer?
Netscape Network is still there, they are still selling Netscape 7.1 CDs plus supports.

I don't think they will get rid of Network Network/AOL screenname sign ins and services.
UserAgent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624 Netscape/7.1 (ax) (CK-SillyDog)
User avatar
Antony
diamond member
diamond member
 
Posts: 15260
Joined: Tue 18 Jun, 2002 11:36 pm
Location: Sydney, Australia

Postby Ramona » Mon 21 Jul, 2003 7:05 pm

Hi Antony,

Testing Streamline 7.1 with Mail & Newsgroups, running Windows 98SE. Let me know if there is anything specific you want tested...

Ramona :mrgreen:
UserAgent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030624 Netscape/7.1 (ax) (CK-SillyDog)
User avatar
Ramona
Moderator
Moderator
 
Posts: 2377
Joined: Wed 19 Jun, 2002 3:50 pm
Location: Midwest USA

Postby Antony » Mon 21 Jul, 2003 9:19 pm

Ramona,
Do you experience with the same resource drainage problem? (Assume with a new profile)
UserAgent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624 Netscape/7.1 (ax) (CK-SillyDog)
User avatar
Antony
diamond member
diamond member
 
Posts: 15260
Joined: Tue 18 Jun, 2002 11:36 pm
Location: Sydney, Australia

Postby Ramona » Mon 21 Jul, 2003 9:32 pm

Yes, the Resource Leak is still there, altho I work around it by reducing the number of tabs I normally use.

I didn't create a new Profile, although I did not have the problem DJGM had, with about:Netscape. I did see the (SillyDog) in the UA. This is the only Netscape I have on the system, and didn't want to create another Profile. I will, tho if it is significant to you...

Sending/Receiving Mail is A-OK, NG all working.
UserAgent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030624 Netscape/7.1 (ax) (CK-SillyDog)
User avatar
Ramona
Moderator
Moderator
 
Posts: 2377
Joined: Wed 19 Jun, 2002 3:50 pm
Location: Midwest USA

Postby Antony » Mon 21 Jul, 2003 9:36 pm

Ramona wrote:Yes, the Resource Leak is still there, altho I work around it by reducing the number of tabs I normally use.
Do you apply the work around you mentioned in your page?

Sending/Receiving Mail is A-OK, NG all working.
Mail is okay for me, but I find Netscape SecureNews is extremely slow, is that just me or the secnews server? (I did not touch NS Mail component.)
UserAgent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624 Netscape/7.1 (ax) (CK-SillyDog)
User avatar
Antony
diamond member
diamond member
 
Posts: 15260
Joined: Tue 18 Jun, 2002 11:36 pm
Location: Sydney, Australia

Next

Return to SD701 DevZone

Who is online

Registered users: Baidu [Spider], Bing [Bot], Google [Bot], Yahoo [Bot]